TYPO3 6 with integrated t3editor in own extbase extension

In a current project of mine, the Fluid Template Manager, I use the t3editor in the developed backend module. Thanks of the great post of the typo3blogger I was able to integrate them easily in TYPO3 4.7.x.
But while preparing our ftm Extension for TYPO3 6.1 there happens a small error.
The page with the t3editor isn’t loading, because there happens a 500 internal server error.

The solution is easy.
By the conventions of the TYPO3-Extension folder structure, the folder classes must be written uppercase first. The corrected TCA-Snippet looks now like that:

'template_code' => array(
    'exclude' => 0,
    'label' => 'LLL:EXT:ftm/Resources/Private/Language/locallang_db.xml:tx_ftm_domain_model_templatefluid.template_code',
    'config' => array(
        'type' => 'text',
        'cols' => 112,
        'rows' => 36,
        'eval' => 'trim',
        'wizards' => array(
            't3editorHtml' => array(
                'enableByTypeConfig' => 1,
                'type' => 'userFunc',
                'userFunc' => 'EXT:t3editor/Classes/class.tx_t3editor_tceforms_wizard.php:tx_t3editor_tceforms_wizard->main',
                'params' => array(
                    'format' => 'html',
                ),
            ),
        ),
    ),
),

By the way, i found out that the cols and rows entries now worked as they should. 🙂

Note: Related to this problem there is another post here, that deals with the integration in different TYPO3 versions.

    • sunny
    • October 3rd, 2013

    pls any body can help me to let me understand how to make ex base extention step by step thanx