Typo3 4.7.4 Installations-Fehler – Class ‚Tx_Extbase_Utility_Extension‘ not found

Heute habe ich mal wieder ein frisches TYPO3 aufgesetzt – natürlich kommt da wie immer nur die neuste Version zum Einsatz.. 😉

Für gewöhnlich, wenn man nicht gerade einen Wald und Wiesen Hoster hat, läuft alles schnell und reibungslos. Dieses mal gab es allerdings eine interessante neue Fehlermeldung:

Fatal error: Class 'Tx_Extbase_Utility_Extension' not found in /var/customers/webs/greeneye/ploom/cms/typo3conf/temp_CACHED_psf69f_ext_tables.php on line 462 

Die Fehlermeldung ist etwas unglücklich und gibt nicht viele Anhaltspunkte darüber was hier schiefläuft. Nach einer kleinen Recherche ist schnell klar, die extBase-Extension ist zwar pysikalisch vorhanden – aber nicht in der Konfiguration eingebunden.

Das Problem lässt sich schnell lösen:

  • localconf.php aus dem Verzeichnis /typo3conf/ zum Editieren öffnen
  • Den untersten Eintrag des $TYPO3_CONF_VARS[‚EXT‘][‚extList‘] finden und am Ende den Eintrag ‚,exbase‘ anhängen. Die neue Zeile könnte nun wie folgt aussehen:
    $TYPO3_CONF_VARS['EXT']['extList'] = 
    'info,perm,func,filelist,about,version,tsconfig_help,context_help,
    extra_page_cm_options,impexp,sys_note,tstemplate,tstemplate_ceditor,
    tstemplate_info,tstemplate_objbrowser,tstemplate_analyzer,func_wizards,
    wizard_crpages,wizard_sortpages,lowlevel,install,belog,beuser,
    aboutmodules,setup,taskcenter,info_pagetsconfig,viewpage,rtehtmlarea,
    css_styled_content,t3skin,t3editor,reports,felogin,form,rsaauth,
    saltedpasswords,extbase';
    
  • Nun noch den Cache leeren. Dazu löschen wir alle mit temp_* beginnenden Dateien aus dem /typo3conf/ Verzeichnis.

..und das war’s auch schon. Ich hoffe das dieser Post auch anderen hilft! 🙂

    • Jogi
    • 7. Okt. 2012

    Danke!

    • Nina
    • 17. Okt. 2012

    Danke,Thomas! Das hat mir sehr geholfen.

    • Sandra
    • 10. Aug. 2013

    Danke, das ist super und jetzt gehts…

  1. Noch keine TrackBacks.